Quais pacotes de desenvolvimento instalar no Linux

Toda vez é a mesma coisa, você reinstala o seu Linux e aí não lembra mais quais pacotes você precisa instalar para começar a desenvolver.

O pacote mais obvio que bem a mente é o build-essential, mas ele sozinho não resolve tudo…

Então resolvi listar os principais pacotes que preciso numa instalação nova do Linux:

sudo apt-get install \
alien \
apt-file \
automake \
bzr \
bison \
build-essential \
checkinstall \
chrpath \
cmake \
codeblocks \
ddd \
doxygen \
eclipse-cdt \
flex \
gawk \
gcc-arm-none-eabi \
gdb-arm-none-eabi \
gperf \
git \
gitk \
help2man \
ht \
libasound2-dev \
libbluetooth-dev \
libboost-dev \
libbz2-dev \
libfontconfig1-dev \
libglew-dev \
libgtk-3-dev \
libhdf5-dev \
libhidapi-dev \
libical-dev \
libicu-dev \
libjack-dev \
libncurses5-dev \
libpython-dev \
libreadline6-dev \
libssl-dev \
libtool \
libtool-bin \
libudev-dev \
libusb-dev \
libusb-1.0-0-dev \
libwxgtk3.0-dev \
libxinerama-dev \
libxml2-dev \
libzip-dev \
meld \
mesa-common-dev \
minicom \
python-wxgtk3.0-dev \
qt4-qmake \
subversion \
vim \
ssh \
texinfo \
verilator \
vym

Estes são os principais pacotes que estou lembrando/precisando no momento. Quando eu lembrar de outros pacotes atualizarei esta lista.

One thought on “Quais pacotes de desenvolvimento instalar no Linux

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s